• 0
Votes
name

A PHP Error was encountered

Severity: Notice

Message: Undefined index: userid

Filename: views/question.php

Line Number: 191

Backtrace:

File: /var/www/html/cnasolution/application/views/question.php
Line: 191
Function: _error_handler

File: /var/www/html/cnasolution/application/controllers/Questions.php
Line: 419
Function: view

File: /var/www/html/cnasolution/index.php
Line: 315
Function: require_once

enter image description here

I'm trying to get PHP 7.4.1 (NTS x64, Zip version) to run on my Windows development machine, but I'm getting the following output in my run window in PhpStorm:

C:path_to_phpphp.exe -S localhost:80 -t C:path_to_my_projectwww [Tue Dec 31 15:42:39 2019] PHP Warning:  'vcruntime140.dll' 14.0 is not compatible with this PHP build linked with 14.16 in Unknown on line 0  Process finished with exit code 1 

I've done some research on the problem and found this existing question that suggests installing the latest Microsoft Visual C++ Redistributable for Visual Studio 2019 found here. I installed the latest x64 version and restarted my computer but to no avail, I still get the exact same error message. I have also tried running the installer again and done a repair+restart, but that didn't help either.

Running php -i in the command line works flawlessly, and displays the configuration info for PHP 7.4.1, which is the same PHP instance I'm trying to run in PhpStorm.

The same problem occurs with PHP 7.4, but PHP 7.3 works like a charm. I'm at a loss. Has anyone had the same problem, and found a solution?

Download script demo [LINK]
Download script demo [LINK 2] Download script demo [LINK 2]